LNMP升级WordPress需要ftp信息解决方法

自动把blog搬家之后还没有测试使用过,刚刚想起来更新一下wordpress的版本,然后发现要输入用户名和密码,之前其实也遇到过。

vps没有使用面板,使用的是军哥的lnmp一键安装包环境,其实如果通过命令行安装 WordPress 后,遇上提示更新升级、包括安装新的插件和主题的时候,都会出现需要填写 FTP 相关信息的情况,相当不方便。其实发生这种提示需要ftp信息的时候,只需要在服务器内做一些文件权限的修改变可以,因为发生这种情况主要是网站目录的权限执行身份非文件所有者身份。

解决方案如下:

假设你的 WordPress 安装目录为 /home/wwwroot/www.dingguohua.com

用 ssh客户端登录 Linux VPS ,执行:

chown -R www /home/wwwroot/www.dingguohua.com

执行上面的命令就可以将 /home/wwwroot/www.dingguohua.com 下所有文件的属主改为 www ,这样就可以解决自动更新必须填FTP的问题。

基本上按以上方法就可以解决问题,如果还不能正常成功更新,可以尝试修改 wp-config.php 文件

在 wp-config.php 中加入一行代码

define(‘FS_METHOD’, “direct”);

发布者

admin

出生于湖南安乡,现居住于浙江绍兴,持续创业者。

发表评论

电子邮件地址不会被公开。 必填项已用*标注